Elasticsearch Index Status is ‘yellow’ or ‘red’
The article provides a fix for when the Elasticsearch Index Status is not ‘green’. ‘yellow’ indicates normal, and ‘red’ indicates bad. The ‘yellow’ or ‘red’ status may occur in conjunction with missing products or the display of old product information.
Affected versions and products
- Adobe Commerce on cloud infrastructure 2.2.x, 2.3.x
- Adobe Commerce on-premise 2.2.x, 2.3.x
Issue
The Elasticsearch catalog search index is slow, resulting in a status of ‘yellow’ or ‘red’ rather than ‘green’. You may also experience missing changes on the frontend.
Cause
There can be several potential causes. One cause is the Elasticsearch instance running out of disk space. Another cause is duplicated indices.
Solution
Create a fresh mysql dump before following these steps and perform them outside of business hours to avoid potentially affecting your clients:
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Switch temporarily to MySQL search – enable MySQL search. (Note: Remember to switch back to Elasticsearch or you may experience performance issues).
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To identify duplicated indexes run the following command:
code language-none curl --silent -X GET localhost:9200/_cat/indices?v
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To delete indexes:
code language-none curl -XDELETE localhost:9200/[your_index_name_here]
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Reenable Elasticsearch.
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Run full re-index.
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Check indexes status by running the following command:
code language-none curl --silent -X GET localhost:9200/_cat/indices?v
If these steps don’t work, submit a support ticket.
Related reading
To learn more, refer to Elasticsearch Cluster health API.